Con la nueva versión de Openstack (Pike) han surgido algunos problemillas a la hora de realizar la instalación tal y como estaba planteada en nuestro ebook y esto nos ha reportado errores tipo: Error: Package: python2-matplotlib.

error python 2 openstack

En el error además hace una referencia a Openstack Pike.

Estos errores son debido a que faltan una serie de repositorios a la hora de instalar paquetes de Openstack.

Vamos a solucionar el Error: Package: python2-matplotlib al instalar Openstack Packstack.

La forma mas sencilla es añadir estos repositorios antes de ponernos a instalar los paquetes:

subscription-manager repos –enable=rhel-7-server-optional-rpms –enable=rhel-7-server-extras-rpms –enable=rhel-7-server-rh-common-rpms

En especial el repositorio «rhel-7-server-optional-rpms» es el que no estaba incluido anteriormente.

Una vez realizado esto volvemos a lanzar los pasos posteriores:

yum update -y

yum install -y openstack packstack

yum update -y

packstack –allinone

Ahora ya no deberías tener ningun tipo de error.

Espero que te sea útil y te ayude a resolver el Error: Package: python2-matplotlib